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Data 
An understanding of the use of data is essential to most 
Timestone Software programs. 

Introduction 

Although the use of data is optional, through the use of data, users can achieve 
great levels of automation and customization allowing them to save time.  

Data is an all‐encompassing term that refers to any amount of information about 
an image or collection of images or an individual or group of individuals i.e. 
subjects.  

At one level data can simply be an image filename or it can be comprehensive 
information about a high school student such as the student’s name, class and 
teacher or a soccer player’s name, team, number and field position. 

Data is usually (but not always) associated or linked to an image or group of 
images – a process called “matching”. In such cases the data and image are said to 
be “matched”.  

Details Mode 

For the most part, data is handled in Details Mode, which performs the following 
two key functions: 

1. Define fields that are used to hold data 

2. Import or manually enter data into these fields 

However it would be a mistake to think of Details Mode only in those terms. A 
more comprehensive (but not exhaustive) list would also include: 

• Matching subject data to images automatically by importing a text file 

• Checking to see if a subject is matched to an image 

• Quickly finding the image filename of a subject’s main image 

• Entering orders 

• Organising subject data into logical folder groups such as teacher, grade, 
homeroom, team etc 

• Controlling back printing 

• Exporting data as a text file 

Data 
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Details Mode is present in the following Timestone Software applications. 

• NeoPack/Professional 

• NeoComposite 

• NeoGroup 

• DataPost 

• PackBuilder 

• CompositeBuilder 

• GroupBuilder 

• OutPost and NeoPack/Plus* 
 

Note: Although NeoPack/Plus and OutPost do not have a Details Mode they do handle data and allow 
user-defined fields. Therefore much of what is discussed in this chapter can also be applied to these two 
programs. 

 

The Details Mode Window 

To enter Details Mode either select Mode>Details from the menu bar or use the F4 
function key on the keyboard. 

The main area of the Details Mode window is divided into the following key areas. 

1. The main section on the right displaying subject data 

2. The upper left pane showing the folder structure 

3. The lower left pane showing File or Folder fields 

Each of the window panes can be sized independently by “grabbing” a window 
frame and re‐positioning as desired. 

Details Mode 
 



  3 

 

 

 

Details Mode 
 

Folder Structure 

The Details Mode Window 

The main section of the Details Mode Window shows subject fields together with their values in a columnar “spreadsheet” 
format with the field names across the top and the data for each subject in horizontal rows.  
Subject data can be logically grouped into “virtual” folders – folders that exist in the software only, not on the computer hard 
disk.  Typical groupings in school photography could be by Teacher or Homeroom. The upper left windowpane shows the folder 
structure and folder names. Selecting the “All” folder will show all subject records in the main section whereas selecting a 
particular folder will only show subjects that belong to that particular folder. 
The windowpane at the lower left shows either File Fields or Folder Fields depending on what is selected in the Folder Structure 
view above. If the “All” folder is selected then the lower left windowpane will show File Fields together with their values. 
However selecting a particular folder in the Folder windowpane will display Folder fields and the values of those fields for the 
selected folder. 
 

File or Folder Fields   Subject Fields  
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Data Fields 

Fields can be considered placeholders for storing data of a similar type and 
format. So, for example, a field called “Firstname” would hold the first name of a 
particular subject or record. 

Timestone Software allows the user to define their own fields before populating 
them with data. Furthermore three levels of fields are available 

• Subject fields – contain data for each individual record or subject 

• Folder fields – contain data common to a particular folder of subjects 

• File fields – contain data common to every subject 

Subject fields 

Subject fields are the most commonly used field type. They describe each 
individual subject in a particular job.  Typical subject fields include firstname, 
lastname and ID. 

Folder fields 

Timestone Software allows subjects to be arranged into groups or folders. This 
makes for better data management and facilitates the ordering of group specific 
products such as class composites, memory mates and more. 

In school photography typical folders may be teacher, grade or homeroom 
whereas sports photographers may arrange their subjects according to the team 
or coach.  

Folder fields therefore contain data that is common to a particular folder (and by 
definition all subjects within that folder). 

File fields 

Data that is common to all subjects can be contained in File Fields. Typical 
examples include schoolname, schoologo and job number. A File Field is the 
equivalent of having a Subject Field with the same data for every subject in the 
job. 

 

Note: An important distinction between the field types is that only Subject Fields allow the direct 
importing of data from a text file. This concept will be discussed in detail later in this chapter. 

 

Data Fields 
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Working With Fields 

An important aspect of Timestone Software is that fields are user definable. This 
means fields can be customized depending on the type of job at hand.  For 
example the set of fields needed for school photography jobs will be different to 
those for sports photography jobs and so on. 

Field Types 

Fields are defined as a certain type depending on the nature of the data they will 
contain. Timestone Software allows four different field types. 

1. Text 

2. Integer 

3. Date 

4. Graphic 

Text Fields 

Text fields are by far the most common field types. Use text fields for data such as 
name, ID etc. 

Integer 

Seldom used, the Integer field type is used for number data. Note that numerical 
data such as ID, phone numbers, height, weight and age are really just text values 
and should be entered into text fields. 

Date 

The date field type is used when the data will be in date format such as dd/mm/yy 

Graphic 

The graphic field type is used when a graphics file (jpeg, png etc) is to be imported 
into the field. This is one way to associate graphics such as a school logo to a job. 
Graphic fields are usually almost always File or Folder fields. 

Field Types 
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Field Special Properties 

In addition to being of a certain type, fields can also be assigned a special property 
that “tells” the software something about the data in the field. This allows the 
software to make better use of the data and assists in automating certain tasks.  

For example a subject field can have the special property of First Name. This 
means the software knows that data in this field is the subject’s first name 
regardless of what the field may be called. 

Field special properties are used exclusively with subject fields and are listed in 
the table below. 

 

Special Property  Description 

Whole name  The entire name 

First name  The first name 

Last name  The last name 

Middle name  The middle name 

Birthdate  The subject’s date of birth 

Unique field  The field that uniquely identifies the subject 

 

Note that many if not most of the fields you may use do not have any special 
property and so a “none” option is available for these fields 

Field Properties 
 

The Unique Field 

Of the special properties listed above the unique field deserves special consideration.  
The unique field is the field that contains unique data for a given subject and is therefore used as the basis for identifying each 
subject. Any two subjects that have the same value for the unique field will be considered as the same subject.  Or, put another 
way, no two subjects can have the same value for the unique field. 
Typically the unique field is a subject ID. In school photography this is quite often (but not always) the same ID assigned by the 
school itself. In the absence of such a unique value, Details Mode provides a “Populate Field” function to assign each subject a 
unique value. 
The unique field is often used in barcodes as a means of quickly finding a subject in CapturePost and in many other areas of the 
software. 

 

MORE INFORMATION 
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Defining Fields 

The software already has a set of pre‐defined subject fields saved as program 
defaults. You may elect to keep and use these fields, edit them, add more fields or 
remove them entirely.  

The pre‐defined fields are Lastname, Firstname, ID and Birthdate. 

Adding, removing and editing fields 

There are several ways of defining a set of fields for a job. These include: 

• On a job by job basis. Define a set of fields that will be used for the current 
job only. 

• As program defaults. Define a set of fields as defaults that will be available 
whenever a new job is started. 

• As part of a workspace. Define a set of fields inside a workspace. These 
fields will be available whenever a new job is started in that workspace. 

• From a master or pre­existing job. Start a new job based on an existing 
job. The fields in the new job will be the same as those of the master job. 

 

To add, remove or modify fields: 

1. Start a new job (File>New) or open an existing job (File>Open) 

2. Go to Details Mode>Edit>Fields … 

3. The Detail Fields window is presented 

4. Select either the Subject Fields, Folder Fields or File Fields tabs as needed 

5. To add a field click the Add button 

6. Enter a name for the field, the field type and if appropriate, the field special 
property 

7. Click the Add button again to add more fields 

8. To delete a field, select it first then click the Remove button 

9. To edit a field, select the field name , type or property and modify as 
needed 

10. Click the OK button when done to accept the changes or Cancel to discard 
them 

 

Installation 
 

Adding Fields 
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Default Fields 
 

The Detail Fields window is where fields are added, 
removed and modified. It is used in various areas of the 
software including: 

1. In Details Mode>Edit fields … when defining 
fields for the current job 

2. In File>Options>Default … when setting fields 
as program defaults 

3. In File>Workspaces … when setting fields for 
a workspace 

The screen grab shows the pre‐defined subject fields 
that are set as program defaults when the software is 
installed. These subject fields are program defaults and 
will be used whenever a new job is started. As we shall 
see you can add, remove or edit any of these fields. 

Note the three tabs, each displaying the different field 
levels – Subject, Folder and File fields. Click each tab to 
define or modify each of these field types. 

Fields are of a certain type depending on the format of 
the data they will hold.  Most fields are text fields even 
if the data is actually a number. 

Subject fields can have special properties that help the 
software make better use of the data. Most fields have 
no special property and “none” is set for these fields. 
The default fields set at installation have a special 
property as shown in the screen grab. 

There is no limit to the number of fields you can define. 
For jobs that do not require any data at all you will still 
need to have a field to hold each image’s filename. 
This concept will be discussed in detail later in this 
chapter 

The As tags … button is used to control how data is 
displayed in other areas of the program such as in the 
subject list in Form Packs Mode, below the image 
thumbnails in Match Mode and elsewhere. It is also 
used to control back‐printing. We shall look at the As 
tags … functions later in this chapter. 

. 
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Defining a new set of default fields 

The steps above alter fields for the current job. It is also possible to define fields as 
program defaults. These fields will then be used whenever a new job is started. 

To define default fields: 

1. Start a new job (File>New) or open an existing job 

2. Go to File>Options. The options window is displayed  

3. Click the Default tab 

4. Two options are available to define a new set of fields – either manually or 
by importing from a pre‐existing job 

5. Click the Edit Fields button to be presented with the Detail Fields window. 
Edit the fields as described above 

6. Alternatively click the Import from file button to browse to a job that 
already has the fields you would like as default. 

Default Fields 
 

Fields can be defined as program defaults so they are 
already set when a new job is started. This is done in 
File>Options>Default from any mode other than 
Design Mode. 

You can either define a new set of fields manually by 
clicking the Edit button or import the fields from a job 
you already have by clicking the Import from file 
button and browsing to the job. Note this method 
imports the fields only – not any values (data) entered 
into those fields. 

Fields saved as program defaults are not saved globally 
for all users. Instead they apply only to the current user 
on the current workstation. Furthermore they apply 
only to the current application. For example default 
fields in NeoPack/Professional are not applied to 
NeoComposite. 
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Defining fields inside a workspace 

Workspaces allow the user to setup a working environment that uses a particular 
set of fields, templates and aspect ratio guides. Different workspaces can be 
defined for different job types.  

Workspaces are described in more detail later in this document but for now it is 
useful to know that fields can be defined as part of a workspace. Whenever a job is 
started within a workspace it will use the fields set within that workspace. 

To define fields for a workspace: 

1. Go to File>Workspaces … 

2. Either select an existing workspace or create a new one 

3. To use the program default fields check the use default box. 

4. Alternatively click the Set button to define a set of fields for this workspace 

Once a job has been created inside a workspace, the fields may still be edited by 
going to Details Mode>Edit fields … at any time. 

 

 

Fields in Workspaces 
 

A workspace can use the program default fields or it’s own set of fields. Check the use default box to use the program default 
fields.. Alternatively uncheck the box and click the Set button to bring up the familiar Details Fields window and define fields 
for this workspace. 
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Using Master Jobs 

When starting a new job the user has the option of using either the File>New … 
command or the File>New from file … option. 

File>New from file … starts a new job based on an already existing job – a master 
job. The new job will inherit all the properties and settings of the master job, 
including the Detail Fields.  

To start a new job from a master job: 

1. Go to File>New from file … A New File window is presented 

2. Browse to the master job and open it 

3. A new job including all fields will be created based on the master job file  

 

Note: Compared to the other methods of defining fields, an important difference in setting fields from a 
master job file is that any data in the fields will also be set. This can be a useful way to “pre-enter” data 
into File and Folder fields since these fields cannot be populated automatically by importing a text file. 

 

Using master jobs is an important aspect of Timestone Software and as such will 
be discussed in greater detail later in this document. 

System Fields 

The discussion so far has centred on user’s defining their own fields. Details Mode 
also displays certain “system” fields that are not user definable. These fields can 
be seen in the main windowpane of Details Mode together with other subject 
fields. They are differentiated from the other subject fields by being italicized. 

 

Field  Description 

Folder  Shows the subject’s home folder 

Image  The filename of the subject’s primary image 

Label  A distinctive label for the subject such as Teacher or 
Captain 

Order  Displays order information 

Cost/Paid  The cost of the subject’s order and whether it has been 
paid 

Comment  A general comment field 

 

System Fields 
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Entering Data Into Fields 

In simple terms there are two ways to enter data. 

1. Manually – by entering data directly into a field using the keyboard 

2. Automatically – by importing a text file 

Importing a text file is obviously the method of choice for populating subject fields 
where there can be hundreds if not thousands of subjects.  

However the user must also become familiar with manual data entry as it is used 
to modify data after it is entered and is the only way to enter data into File and 
Folder fields. 

Manual data entry 

Data can be entered directly into a field by simply double clicking the field value 
and entering the data as needed. In the same manner, data can be modified by 
double‐clicking the value and changing the data as needed.  

Once entered, data can be copied from one field to another by right‐clicking the 
mouse and using the Cut, Copy and Paste functions as appropriate. 

Graphic type File or Folder fields 

A special case of manual data entry is importing a graphic into a File or Folder 
field. (Graphics can also be imported into Subject fields but this is rarely done) 

Recall the earlier discussion on field types and how one of the possible field types 
is “Graphic”. This is used to associate a graphic file such as a jpeg or png to a field.  
The graphic can then be used on products by calling the field onto a template. 

Why not place the graphic directly on the template for this product? 

Consider a scenario where your products may require the school logo to appear 
somewhere on the layout. One solution would be to place the logo directly onto 
the template and while this technique works well it means the template can now 
only be used for this particular school. 

An alternative approach is to design the template with a generic placeholder for 
the school logo. We call this placeholder a labelled image holder because it uses a 
label to direct it to retrieve an image by reading the value for a particular field. 

In our example the label could be @schoollogo. The software will now go off and 
search for a field called schoollogo. We would therefore define a file field (type 
graphic) called schoollogo and import the schoollogo file into the field. Whenever 
the template with the @schoollogo labelled image holder is used, it will place the 
school logo onto the product.   

Data Entry 
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Note: The concept of template design and labelled image holders will be discussed in detail later. Indeed 
there are many ways to place graphics onto a product – using labelled image holders with File or Folder 
fields is but one.  

 

Importing a graphic into a File or Folder field 

To import a graphic into a field follow the steps in the box below. The screen grab 
shows the file fields for a particular job. The Schoologo field is a graphic field and 
is distinguishable from text fields by the grey colour of the value area. In this 
example a file called Mater‐Cristi logo.jpg has been imported into the field. 

 

 

Importing a Graphic 
 

1. Go to Details Mode 

2. Click the “All” folder to display File 
Fields or click a particular folder to 
display the Folder Fields for that 
folder 

3. Locate the field to import the 
graphic into. The value area of a 
graphic field is grey compared to 
white for a text field. 

4. Double‐click the value for the 
desired field. This brings up the 
Graphic File window 

5. Click the Select File button to 
browse to the desired graphic file 

6. Click Open to import the file into 
the field 

7. The field now displays the filename 
of the imported graphic file. 

8. To change the graphic repeat from 
step 4, browsing to a different file 

A graphic File Field showing the 
imported graphic’s filename 
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Importing a text file to populate subject fields 

As mentioned previously in most cases it is vastly impractical to enter data 
manually for subject fields. A typical job may have hundreds or even thousands of 
subjects each with several subject fields. This equates to an enormous amount of 
data entry. 

In such circumstances data is usually imported from a text file. The text file is 
normally supplied by the photographer’s client (eg the school) or may have come 
from a database or spread‐sheeting program. 

While the primary function of importing a text file may therefore be considered to 
be entry of data into subject fields, one of the most powerful aspects of Timestone 
Software is the number of tasks that can be performed automatically as the data is 
imported from the text file. 

These include: 

• Matching the data to images 

• Assigning images pose labels or numbers 

• Specifying which image is the primary or main image 

• Setting a background to be used in Chroma Key (Green Screen) jobs 

• Cropping images 

• Editing images for colour, brightness, contrast and saturation 

• Setting a mask for images to achieve transparency or edge effects such as 
vignettes 

• Entering orders for each subject 

Many of the items in the above list may be unfamiliar but will be discussed in 
detail as each topic is covered elsewhere. For now the discussion will centre on 
importing a text file for the purposes of populating subject fields only. This could 
be the case when, for example, a photographer is preparing a job for use with 
CapturePost. 

The text file 

Timestone Software supports text files of the following formats. 

• Fixed length. Fields are a set length with no delimiter between them 

• Comma delimited. Fields are separated by a comma 

• Tab delimited. Fields are separated by a tab 

• Comma Separated Value (CSV). Fields are separated by a comma 

Of the formats above, fixed length text files are rarely seen. The last format, 
Comma Separated Value, is a special example of a text file in that it is directly 
supported by Microsoft Excel. This makes the CSV format especially attractive 

The Text File 
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since a CSV file will open directly in Excel where viewing and editing the file is 
easier. 

CSV files have a file extension of .csv and double‐clicking the file will open it in 
Microsoft Excel. Normal text files have an extension of .txt and will open in the 
default text editor such as Windows NotePad. 

 

 

Data in other formats and from other applications 

It is worth emphasizing that data can only be imported from text files in one of the 
formats listed above.  

Occasionally the user may receive data in some other format such as Microsoft 
Word (.doc), Microsoft Excel (.xls), in a database format such as Microsoft Access 
(.mdb) or from any number of third party applications. In these cases the data 
must be either converted, saved or exported into one of the supported formats. 

The Text File 
 

The screen grab above shows an extract from a simple text file. In this case the file is a Comma Separated Value (CSV) file 
(called MC1.csv) and has been opened in its default application – Microsoft Excel. As can be see the data is neatly 
formatted in rows and columns that makes for easier reading and modification if needed.  

The first row is an optional title line that is useful to clarify the nature of the data in the columns below. When importing 
this text file, we have the option to ignore the first line. 

We shall use the above text file as a sample in the discussion to follow. 
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Importing the text file 

Before a text file can be imported, the software needs to know various attributes 
of the text file such as its format and how the fields in the text file relate to the 
fields we have defined in the software. The latter is achieved via a process called 
“Mapping” which ensures the correct data is imported into the correct field. 

The above is all achieved via the “Setup subject details to import” window – often 
simply referred to as the Setup Import window.  

To begin the import and access the Setup Import window: 

1. Open an existing job or start a new job  

2. Go to Details Mode if not already there 

3. If needed define a set of fields  

4. Go to Subjects>Import text file. You may also use the Ctrl‐I keyboard 
shortcut or the icon on the toolbar.  

5. A window appears allowing you to browse to the text file. Highlight the 
desired text file but do not open it yet 

6. Click the setup button to bring up the Setup Import window. 

7. Specify the text file type. In the Setup window specify the type of text file 
to be imported. In the example above the file is delimited by a comma (a 
CSV file). The Ignore first line option should also be checked to prevent 
importing of the title row 

8. Map the fields. The Field Map shows the fields defined for this job together 
with two special fields – Folder and Label. Map the fields in the job against 
the fields in the text file. In our example the Lastname is field 1, Firstname 
field 2 and so on. 

9. Specify a field to be used to create folders. Map the field that will be 
used to create folders. In our example we could use the Teacher field which 
is field 5, placing the number 5 in the Folder entry in the Field Map 

10. Identify the unique field. If a unique field is present it should be identified 
in the setup by selecting it in the drop down at the upper right of the setup 
window. 

11. Select how to handle any subjects that may already have data.  

12. Click OK to return to the browse window 

13. Ensure the correct text file is selected then click OK to begin the import 

The Text File 
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Import Setup 
 

Map the fields 

Identify the 
unique field 

 

The Text File Import Setup Window 

At first glance the Setup window may appear somewhat daunting with its many options but this reflects the many functions that 
can be achieved when importing a text file. Many of the functions are optional with, for example, the entire lower right section 
only relevant when matching images to data as the text file is imported. This will be covered later. 
The screen grab above shows the parameters for importing the sample text file MC1.csv as discussed earlier. Three essential 
options have been set, namely: 

• Specifying the type of text file and whether to ignore the first line or not 

• Mapping the fields in the software, which are listed in the Field Map pane, against the Field number of the 
corresponding data in the text file. Included in this mapping is specifying which field to use to create folders. 

• Identifying which, if any, of the fields is the unique field 

• Select how to handle any data that may already be there. This will be discussed in greater detail shortly 

 
 

Specify the text 
file type 

Specify how to 
handle any 
existing data 
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Checking the import 

Once the text file has been imported it is worth spending a few moments checking 
Details Mode to ensure the data has been imported as expected.  

Essentially, the Subject Fields area should now be populated with data while the 
Folders pane should display the folders as specified in the Field Map.   

Checking The Import 
 

A quick glance at the Details Mode window will quickly confirm whether data has been successfully imported. The above screen 
grab shows the results of importing the sample MC1.csv file. Errors involved in importing a text file are usually immediately 
obvious and most involve an incorrect mapping of the fields. Some common errors and their causes are listed below. 

• Data did not import at all. The wrong type of file was specified in the import setup. For example the type was 
specified as a tab delimited file when it was in fact a comma delimited text file. 

• Data is in the wrong fields. The field mapping was incorrect. Check the fields are mapped against the correct 
field numbers of the corresponding fields in the text file. 

• Data did not import for some fields only. Again check the mapping to ensure the field was mapped correctly. 
Also check that the field type corresponds to the type of data being imported. For example the Field type may have 
been defined as Date but the data being imported is simple text. 

• Folders not created or the folders are wrong. Again the field mapping was incorrect, Specifically, check what 
field from the text file was mapped against the Folder field in the Field Map 

• Some subjects appear multiple times.  For whatever reason, the text file had multiple entries for the same 
subject. This in itself would not have been a problem had a unique field been present AND the unique field was 
specified in the Import Setup. In this case the subject would only have been imported once. 
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Working with folders 

Folders are an important feature of Timestone Software.  

As we shall see by organizing subjects into folders the software can automate 
several aspects of production.  For example, class composites can be produced 
automatically for an entire school by making use of the folder structure whereas a 
team photo can be linked or matched to a folder thereby making the production of 
memory mates easier. Packages, ID cards, trader cards and more can be sorted by 
folder before printing to allow for easier packaging. These are just a few examples 
that take advantage of folders. 

The “Home” folder 

The folder in which a subject belongs is referred to as their Home folder. As we 
shall see this is an important concept because subjects can be copied to other 
folders but can only belong to one Home folder. 

The “All” folder 

Although not strictly a folder, selecting All in the folder tree displays all the 
subjects in the main window pane of Details Mode. Furthermore any File Fields 
will be displayed in the lower left window pane.  

 

Note: It is possible for a subject to belong to the All folder only without also being part of one of the 
user-defined folders. The reverse is not true. A subject inside a folder will always be in the All folder as 
well. 

 

Creating new folders 

Importing a text file is not the only way to create folders ‐ folders and sub‐folders 
can also be created manually. For example the user may wish to create a folder 
called Staff and move all the staff members from their Home folders to a common 
“Staff” folder. This may require manually creating a Staff folder first. 

To create a folder: 

1. In the folder tree, select the parent folder for the new folder. This is usually 
the All folder unless you want the new folder to be a sub‐folder of an 
already existing folder 

2. From the menu select Folders>New or use the Ctrl‐F keyboard shortcut 

3. A new folder is created. Name the folder as desired 

 

 

Folders 
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Moving, copying and associating subjects from one folder to another 

Subjects do not need to remain in the folder that they were originally placed and 
can be moved or copied from one folder to another, or merely linked (associated) 
to another folder.  

Moving a subject to another folder 

A subject may need to be moved from one folder to another if, for example, they 
were placed in the wrong folder initially or have since moved from one folder 
grouping (class, teacher, team etc) to another. 

To move a subject to another folder: 

1. Select the subject in their original home folder 

2. Drag and drop the subject into the new folder 

The actions above remove the subject from the original folder but do not 
automatically make the destination folder the new home folder.  An examination 
of the destination folder will reveal the subject does not have an entry in the 
Folder column and instead has a “+” symbol indicating the subject originated from 
another folder. 

To complete the process and make the destination folder the new home folder: 

3. Select the subject in the new folder 

4. From the main menu select Subjects>Set home folder or use the Ctrl+H 
keyboard shortcut 

Copying a subject to another folder 

There may be occasions when a subject needs to belong to two (or more) folders. 
Staff in a school photography setting provides a good example. The user may wish 
to create a Staff folder and copy teachers from their original home folder to the 
Staff folder. This will allow, for example, a composite group photograph to be 
created for just the staff members while leaving the teachers in their original 
home folder so they may also appear in a class composite with their students. 

To copy a subject to another folder: 

1. Select the subject in their original home folder 

2. While holding down the Control key, drag and drop the subject into the 
destination folder.  

The subject remains in the original home folder while an examination of the 
destination folder reveals the subject now also belongs to the new folder. 
However the Folder column in the destination folder will display a “+” symbol 
together with the name of the original folder – the home folder. 

 

 

Folders 
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Associating a subject with another folder 

An association links a subject to another folder without moving or copying the 
subject to that folder. 

Associations are normally used to link staff members from their home folder to 
another folder. However unlike the copy action described above an association 
does not make the subject part of the destination folder. So in production for 
example, when the folder is selected as a whole and products ordered, the 
associated subject will not be part of that selection. However any products that 
require the associated subject’s image or data can make use of the association 
through the use of Labels. 

To associate a subject with another folder: 

1. Select the subject in the original home folder 

2. While holding down the Shift and Control keys drag and drop the subject 
into the destination folder 

The subject remains in the original home folder while an examination of the 
destination folder will show the subject with a chain or link symbol in the Folder 
column. 

Folders 
 

The Subjects area of Details Mode with the Miss Smith folder selected. Three subjects have been moved, copied and associated 
from other folders. The Folder column reveals the Home folder of each subject while the symbol reveals the origins of this 
subject with respect to the current folder. 

• Home Folder. Jonathon Angliss is in his Home folder. The Folder column displays Miss Smith (the currently 
selected folder) together with a diamond symbol. 

• Move. William Frances has been moved to this folder.  The + symbol indicates the subject has come from 
elsewhere but otherwise the column is empty indicating the subject does not have a Home folder. Use Ctrl+H to set 
this folder as the Home folder 

• Copy. Eva Gabor has been copied from the Mrs Black folder. Mrs Black is still the subject’s Home folder 

• Associate.  Simone Voekler has been linked or associated from the Mrs. Jones folder as indicated by the chain‐link 
symbol. Mrs Jones remains the Home folder 

Home Folder 

Move 

Copy 

Associate 
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Editing Subject Data 

Subject data can be edited (added, modified or deleted) at any time and as with 
entering data initially, edits can be performed manually or by importing a text file.   

Subject data can only be edited in Details Mode. 

Adding a new subject 

To add a new subject: 

1. Select the folder into which the new subject is to be added or select the All 
folder if the subject will not belong to a folder 

2. Enter data for the subject for each field 

If the subject has been added to a folder that folder will automatically become the 
subject’s Home folder and the Folder column will update to reflect this. However if 
the subject has been added to the All folder only, the subject will not have a Home 
folder and the Folder column will be empty. 

A new subject can be moved, copied or associated to another folder as described 
in the previous section. 

Deleting a subject  

To delete a subject or subjects from a folder only: 

1. Select the folder containing the subjects 

2. Select the subject or subjects to be deleted 

3. Press the delete key or select Edit>Delete from the main menu 

The steps above will remove the subjects from their folder but not from the All 
folder. An inspection of the All folder will show the subjects are still there but with 
no entry in the Folder column. 

To delete a subject entirely: 

1. Select All in the folder tree 

2. Select the subject or subjects to be deleted 

3. Press the delete key or select Edit>Delete from the main menu 

Deleting a subject from the All folder will also remove them from any folders. 
 

Note: If the subject already has images matched to it, the user has the option to delete the subject data 
together with the images. In this case select Edit>Delete along with images(s) in the menu or press 
Alt+Del 

 

Editing Data 
 



  23 

Changing subject data 

To edit subject data: 

1. Double‐click the value for the subject to be edited 

2. Edit the data as needed 

If the subject is in more than one folder (as a result of a copy or associate action) 
the subject value will be updated in all folders. 

Duplicating a subject 

A subject can be completely duplicated whereby a new subject is created with 
identical data to the original. 

Importantly the duplicate subject will have the same unique field value as the 
original but will be considered a separate subject. This has important implications 
in production and care must be taken with respect to production steps such as 
ordering and exports to prevent unwanted “doubling up”. 

To duplicate a subject: 

1. Select the subject or subjects to be duplicated 

2. Press Ctrl+D or select Edit>Duplicate … from the menu 

The duplicate subject is created in the same folder as the original.  
 

Note: If the subject already has images matched to it, the user has the option for the duplicate subject to 
also be matched to the same image or images. Select Edit>Duplicate along with images(s) … from the 
menu or press Shift+Ctrl+D 

 

Changing the case of subject data 

It is possible to have the software automatically change the case of any subject 
text field without the need to manually edit the data or re‐import a text file.  

This feature can be very useful if for example, the names of subjects have been 
imported in upper case such as JOHN SMITH but the user requires the names to be 
in “name” case – John Smith. 

Data can be changed to: 

• All uppercase 

• All lowercase 

• Name case where only the first letter is in uppercase 

To change the case of data in a subject field: 

1. In Details Mode select Edit>Change field case … 

2. The Change field case window appears.  

Editing Data 
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3. Select the desired field. Only text fields can have their case changed 

4. Select whether to change the data to uppercase, lowercase or name case 

5. Click OK to change the case as desired 

6. Repeat the process for other fields as needed 

Changing to name case for “special” names 

The most common use of changing the case of subject data is to change the case of 
subject’s names. With this in mind it is important to understand how certain 
names are handled when changing from uppercase or lowercase to name case 

• Mc as in McDonald or McKenzie. When the software encounters Mc as 
the first two letters it will always capitalize the third letter 

• Mac as in Mackie or Macie. Names beginning with Mac cannot be treated 
as those beginning with Mc since there are two many names where the 
fourth letter should not be capitalized. 

• Hyphenated names and names with apostrophes as in Smith­Kline 
and O’Reilly. The software will always capitalize the first letter after a non 
alphabet character 

• Names with spaces as in Van Der Haar and Van Essen. The first letter 
after a space will always be capitalized 

Editing Data 
 

The Change field case feature is a very useful method 
for changing subject data from one case to another.  

Although mainly user for subject names it can be used 
for any text type subject field. 

Select the field from the drop down list then select the 
case to change the data to 
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Editing subject data by importing a text file 

As we saw when importing a text file earlier, the user has several options when 
importing a text file into a job that already contains subject data.  

This situation may arise for several reasons but is normally only used when 
several edits or additions need to be performed and the task is too great for the 
manual methods discussed above. 

The text file is imported in the same manner as described earlier however 
attention now needs to be given to the section “When importing details for 
subjects that already have details set” in the Text Import Setup window. 

It is important to understand these options only apply to subjects that are already 
in the job. Any new subjects in the text file will be imported as normal. 

Four options are available.  

• Leave existing details. The incoming data will be ignored. 

• Replace all existing details.  The incoming data will replace all existing 
data even if the incoming data is blank for any fields 

• Only replace existing fields if blank. Existing subject data will be 
replaced only if the existing field is blank 

• Update existing fields. Existing data will be replaced with incoming data 
only if the incoming data is not blank  

 

Note: In order to ensure the data is updated correctly it is critical to make sure the unique field in the 
incoming text file matches the unique field for the data already in the job. 

 

Editing Data 
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Populating a field with unique data 

Timestone Software provides a very useful feature called Populate Field to 
automatically enter unique data into a subject field.  

The feature is most often used to assign a unique value to subjects that do not 
inherently have a unique field, as is often the case in elementary school or youth 
sports jobs for example. Even in jobs where subjects do have a unique ID, 
Populate Field can be used to assign each subject a unique password to be used in 
situations such as online ordering or wherever there is a need to enter unique 
data for each subject. 

To populate a field go to Details Mode>Edit>Populate field … to display the 
Populate Field window and work through the parameters as listed below. 

Populate Field 
 

Select the field to be 
populated 

Options for populating 
with a sequential number 

Options for populating with a 
random number, text or both 

Enter the length of 
characters and a prefix if 
needed 

1. Select which subject field to 
populate from the drop down list 

2. Select whether to populate the 
field with a sequential number or 
a random number or text.  

3. If using Sequential number, enter 
the starting number and whether 
to insert any leading zeros 

4. If using random numbers or text, 
select whether to use numbers 
only, text only or a combination of 
both 

5. Set the number of characters to 
use – the minimum is five 

6. Enter a prefix if the data is to be 
prefixed with a fixed value 

7. Select how to handle data that 
may already be in the field 

8. Click OK to populate the field 

 

Specify whether to 
overwrite any existing data 
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Exporting data 

All subject data can be exported as a text file that can then be used in other 
applications as needed. Furthermore it is possible to export additional data about 
a subject that is not necessarily one of the user‐defined fields. Examples of such 
data include the image filename, pose label, order information and much more. 

To export a text file: 

1. In Details Mode select Subjects>Export text file … or use the Export 
Subjects icon on the toolbar 

2. Click the Setup button to bring up the Text file export window 

3. Specify the type of text file to be exported. The default is comma delimited 

4. Click the New button to add a new field to the Field map 

5. Click the Field value to reveal a drop down list of all subject fields in the job 
together with several special fields (distinguished by square brackets) 
available for export. Select the field to be exported 

6. Click the New button again to repeat the process for the next field. 
Continue until all the desired fields have been selected 

7. To remove a field, select it then click the Remove button 

8. Use the up and down arrows to change the order of the fields if needed 

9. Select how to handle subjects matched to more than image 

10. Click OK to return to the Text file to export window 

11. Browse to the location where the file is to be exported and give it a name 

12. Click OK to export the text file 

 

Note: The steps above export a text file only. It is also possible to run pre-defined exports for companies 
such as yearbook publishers and school administrator software. These exports deliver both a text file 
and images all formatted as required by the company in question. Such exports can be found under 
File>Export and will be discussed in detail later in this chapter. 

 

Exporting Data 
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Special fields that can be exported 

Below is a list of “special” fields that can be exported into a text file.  
Field  Description  Example(s) 

name  The contents of the firstname and 
lastname fields 

John Smith 

folder  The subject’s home folder  Mrs. Jones 

label  The contents of the label field  teacher 

image‐number  The image number  21 

image‐tag  The image file name without the 
extension 

DSC001 

image‐filename  The image filename complete with 
extension 

DSC001.jpg 

image‐path‐filename  The image filename including the full 
path to the image 

C:\Images\DSC001.jpg 

image‐correction  Image edit values for intensity, color 
and saturation 

 

image‐cropping  Image edit values for zoom and left 
and right pan 

 

image‐pose  The pose label for the image  2, full length 

image‐mask‐on  Whether image masks is set to on or 
off 

0 for off, 1 for on 

image‐mask  The mask applied to the image  vignette.jpg 

image‐background‐on  Whether image backgrounds is set to 
on or off 

0 for off, 1 for on 

image‐background  The background set for the image  blue.jpg 

image‐chromakey  The chromakey profile for the image   

order‐code  The code for any products ordered  /PGV3 for a product 
whose code is GV3 

order‐description  The literal description given to the 
layout 

Portrait Pack GV3 

order‐cost  The cost defined for a package  $11.25 

order‐paid  Whether or not the order is paid  0 for no, 1 for yes 

order‐comment  The value of the comment field  Credit card declined 

retouch‐flag  Whether retouching has been 
ordered for the subject 

0 for no, 1 for yes 

queue‐packs     

     

 

Exporting Data 
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As we shall see later in the discussion on ordering and printing, it is also possible 
to export a text file in NeoPack/Professional and PackBuilder’s Form Packs Mode. 
This text file is a statistical report based on items printed and while it is not 
relevant here is mentioned now for the purposes of completeness. 

 

 

Exporting Data 
 

Specify the type of 
text file to export 

Subject fields to be 
exported 

Special fields to be 
exported 

Handling subjects 
matched to multiple 
images 

Use the text file export window to specify 
which fields to export. 

Any subject fields can be exported together 
with extra data for each subject as 
designated by the “special” fields enclosed in 
square brackets. 

For jobs where subjects may be matched to 
more than one image (multi‐pose shoots for 
example) the user can elect to export a 
separate line for each image. 

Text files exported in this way are most often 
used as a means of obtaining data out of a 
Timestone Software job and into third party 
applications such as accounting and 
invoicing software.  

Text file exports should not be confused with 
the many pre‐set exports available for 
yearbook manufacturers and school 
administrator programs that export both 
images and a text file to the specifications 
required by the company. Such exports can 
be accessed via File>Export and will be 
discussed later 
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Image handling via data 

One of the most powerful aspects of Timestone Software is the amount of “work” 
that can be done with images by importing a text file.  

A text file can be used to import images together with subject data and match the 
two automatically in one step. Or, if the images are already in the job the text file 
can populate the subject fields and match the data to the images. Data can also be 
used to crop and edit images, assign pose numbers to images or place a new 
background behind an image for Green Screen jobs. 

Importing data and matching to images 

Earlier in this document we discussed importing a text file to populate subject 
fields. The import process was setup via the Text File Import window. We now 
return to this important process to not only import data but also match the data to 
images already in the job. 

 

Note: For more information regarding importing images into the software refer to 
blah,blah,blah,blah,blah,blah 

 

The text file 

The text file required for matching data to images must somehow relate to the 
images in the job. Essentially this can be achieved in two ways. 

• The data in the text file is in the same order as the images in the job 

• The data in the text file has a field that references the images 

We shall look at each of these scenarios in turn. 

Images and data in the same order 

One way for the data to be matched to the images is for the data in the text file to 
be in the same sequential order as the images already in the job.  

Each line in the text file belongs to one image in the job with the first line 
belonging to the first image, the second line belonging to the second image and so 
on.  This sequential relationship between data and images is all that is needed ‐ 
there is no need for a field in the data to reference the images. 

 

 

 

 

Image Handling 
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To import the text file we return to the Text File Import Setup window as 
described earlier. Fields are mapped as before with the following additional steps 

1. Check the Match with images as well option. This will enable further 
selections. 

2. Select Match according to the order in the file  

3. Click OK to begin the import 

The text file references the images 

An alternative to having the data in the same order as the images is for each line in 
the text file to have a field which references the corresponding image. This 
reference could be either: 

• The image number (as it appears in Images Mode)  

• The image filename (the most commonly used option) 

• The image tag (the image filename without the extension) 

 

When importing this text file, fields are mapped as before with the following 
additional steps. Step two assumes the reference in the text file is either the image 
filename or the image tag (filename without extension) 

1. Check the Match with images as well option.  

2. Select Match according to the (image-id) field then tag.  

3. Step two will present an additional field in the Field Map – Image-id 

(number/tag/filename). Map this field to the field in the text file with the 
image filename – field 5 in the sample text file above. 

4. Click OK to begin the import 

Importing Images 
 

A text file showing the 
additional field with the 
image filename.  

In this example each 
subject has three images. 
The subject data will only 
be imported once but will 
have three images 
matched to it. 
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Sequence‐code 

As we have seen, when selecting Match with images as well then Match 
according to the (images-id) field the user has three options to select the 
image‐id. 

• Number – when the image‐id is the image number 

• Tag – when the image‐id is the image filename with or without extension 

• Sequence‐code 

Sequence‐code is a special situation and now seldom used. It was developed when 
films were scanned and each image given a unique code corresponding to a roll 
and frame number. Third party software was then used to generate a text file that 
ordered product for each code. The text file was in the same sequence as the 
images (hence the term “Sequence‐code”) however there could be multiple 
entries for the same image (code) since each line would order a different product 
for the image. 

Consider the text file extract in the screen grab below. The first subject, Madeline 
Rosen, has three entries all referencing the same image or code. The second 
subject, Simon Voekler has four lines with the first two referencing one image and 
the next two referencing another. 

To import this text file and match to the images already in the job it is necessary 
to select the Sequence-code option.  Once again an additional field is presented 
in the Field Map and is mapped to the Code field in the text file (Field 5 in the 
sample below). 

With this option the software matches the first subject to the first image then 
checks the image‐id field for a change in code: 

• If the value doesn’t change then there is no need to import (and match) the 
data again and continues to the next line in the text file. 

• If the code does change but the unique field doesn’t then the subject is the 
same and there is no need to import data again. The subject will be 
matched to the next image.  

• If both the code and unique ID change then a new subject is imported and 
matched to the next image 

Sequence code 
 

An example of where the 
sequence‐code option is 
used. 

This user’s text file has 
multiple lines for the 
same image to 
accommodate different 
orders for the same 
image. 
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Importing images via a text file 

The previous two scenarios imported data after images were already in the job. 
The data was automatically matched to the images as the text file was imported. It 
is also possible for the text file to not only import data but import the images at 
the same time, matching them to the data in the one step. 

The text file 

The text file when importing images differs from that used for importing only data 
in that it requires a field that references the image to be imported.  

This additional field can contain either: 

• The full image path and filename. The location of the text file and the 
images is not relevant. 

• Just the image filename. Either the text file or the images need to be in a 
certain location. 

Furthermore if the subject is to be matched with more than one image (as occurs 
in multi‐pose shoots for example) each image will require its own row in the text 
file.  

Location of the text file 

If images are to be imported via the data then it stands to reason the software will 
need to know where to find the images. 

If the text file has the full image path together with the filename then the software 
will know how to locate the images. The user just needs to make certain he or she 
has access to the location in question particularly when the images are on a 
network server. 

 

Tip: When including the full image path and filename it is recommended to use the UNC (Universal 
Naming Convention) format especially when images are stored on a remote server on the network.  

 

On the other hand if the text file contains only the image filename then either the 
text file must be in a specific location or the software must be told where to find 
the images.   

Three options are available: 

• The text file must be in the same folder as the images being imported 

• The images must be in the same folder as the currently open job 

• The images must be in a folder called jobname#images where jobname is 
the name of the currently open job and the jobname#images folder is in the 
same directory as the currently open job 

Importing Images 
 
Importing Images 
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Importing the text file 

To import the text file we return to the Text File Import Setup window as 
described earlier. Fields are mapped as before with the following additional steps 

1. Check the Match with images as well option. This will enable further 
selections 

2. Select Match according to the (image-id) field then filename (import 
images) 

3. Step two will present an additional field in the Field Map – Image-id 

(number/tag/filename). Map this field to the field in the text file with the 
image filename 

4. Click OK to begin the import 

 

Note: The import process will be slower when compared to importing just data since images are also 
being imported (and matched). 

 

Importing Images 
 

Importing data and matching to images or importing the data and images in one step requires some additional options to be 
selected in the Text File Import Setup window compared to only importing data as described earlier. Note the extra field to map – 
the Image‐id field – which is present in the Field Map when the Match with images as well option is checked. In this example the 
images will be imported with the data since the filename (import images) option is checked 

Map the 
Image‐id field 

Check the Match 
with Images as 
well option 

Select to match 
and import 
images  
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Checking the import 

In addition to checking data has been successfully imported, it is worthwhile to 
check the data has been correctly matched to the images have also been imported 
and matched correctly. There are several ways to do this: 

• The Images field in Details Mode will now display the filename of the main 
image for each subject 

• Images should be present in Images Mode with data beneath each image 

• Images should be present in Match Mode with data beneath each image 

Even if the images were not imported with the data and the text file was used to 
just to import and match the images, the above checks are still useful. 

Importing and editing images via a text file 

A look at the Text File Import Setup window above will show that many image 
attributes can be set when importing and matching images with a text file.  

Each attribute requires an additional field in the text file. The one text file can set 
as many of these attributes as needed although the samples below will look at 
each one independently. 

Checking the attribute in the setup will present an additional field to map in the 
Field Map which is mapped to field number in the text file in the usual way.

 

Note: The discussion that follows will focus merely on setting the image attribute via data. The attribute 
itself together with its broader use will be discussed in detail in the section on Images 

 

Set pose 

For multi‐pose shoots this option assigns a pose label to the images. The label can 
be any alphanumeric character or characters. Often the label is simply progressive 
numbers (1,2, etc) but can also be more descriptive such as “Formal” or “Fun”. 

The text file extract below will assign the pose labels 1,2 and 3 to respective 
images. 

23432,Joanna,Liederman,8A,100.jpg,1 

23432,Joanna,Liederman,8A,101.jpg,2 

23432,Joanna,Liederman,8A,102.jpg,3 

Checking the Set Pose option in the setup will present a field called Image-pose 
in the Field Map. In the sample text file above this would be mapped to field 6. 

Edit images via data 
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Set primary 

In multi‐pose shoots (or whenever a subject has been matched to more than one 
image) the user has the option of selecting which image is the main or primary 
image that will be used for production. 

When importing images via data, to explicitly mark an image as the primary image 
simply add a field with any keyboard character. The text file extract below assigns 
image 124.jpg as the primary image for Joanna Liederman. 

23432,Joanna,Liederman,8A,123.jpg,, 

23432,Joanna,Liederman,8A,124.jpg,P, 

23432,Joanna,Liederman,8A,125.jpg,, 

Checking the Set Primary option in the setup will present a field called Image-
primary in the Field Map. In the sample text file above this would be mapped to 
field 6. 

Set background 

When using the Timestone Software Chroma Key (Green Screen) module there 
are many methods to set a new background including by importing a text file. 

To set a new background an additional field is required in the text file with the 
name of the background. The text file extract below will set backgrounds 
marble.jpg, red.jpg and flags.jpg to the respective images 

John, Smith,2222,100.jpg,marble.jpg 
Alan,Martin,3333,101.jpg,red.jpg 

Steve,Bratt,4444,103.jpg,flags.jpg 

Checking the Set background option in the setup will present a field call Image-
background in the Field Map. In the sample text file above this would be mapped 
to field 5. 

Set mask 

In a similar manner to setting a new background for use with the Timestone 
Software Chroma Key Module, it is possible to set a mask for an image via data. 
This is one method of achieving effects such as vignetting. 

The text file will require a field with the name of the file to be used as the mask. 
The sample below will apply a mask called vignette.jpg to one of Alan Martin’s 
images but not the other. 

Alan,Martin,3333,101.jpg,vignette.jpg 

Alan,Martin,3333,102.jpg 

Checking the Set mask option in the setup will present a field call Image-mask in 
the Field Map. In the sample text file above this would be mapped to field 5. 

Edit images via data 
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Set cropping 

It is possible to crop images as they are imported via the text file. For this to occur 
the parameters that must be specified are: 

• left and right movement (X or horizontal pan) 

• up and down movement (Y or vertical pan) 

• scale (zoom factor as a percentage) 

This can be represented generically as ±X/±Y/Scale and a sample text file may 
contain the values: 

John, Smith,2222,100.jpg,+3/‐2/105, 

The values above would crop image 100.jpg for John Smith by moving the image 3 
units to the right, 2 units down and would zoom the image to 105% of its original 
size. 
Checking the Set cropping option in the setup will present a field call Image-
cropping in the Field Map. In the sample text file above this would be mapped to 
field 5. 

Set correction 

In a similar fashion to cropping images it is also possible to color correct images 
via data.  The parameters that can be edited are: 

• Intensity (or brightness) 

• Contrast 

• Red 

• Green 

• Blue 

• Saturation 

This can be represented generically as I/C/R/G/B/U and a sample text file may 
contain the values: 

John, Smith,2222,100.jpg,+5/‐2/‐5/0/0/+10, 

The values above would increase brightness by 5 units, reduce contrast by 2 units, 
reduce red by 5 units, leave green and blue unchanged and add 10 units of 
saturation. 

Checking the Set corrections option in the setup will present a field call Image-
corrections in the Field Map. In the sample text file above this would be mapped 
to field 5. 

Edit images via data 
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Set retouch 

It is possible to mark or flag a subject’s images as requiring retouching when 
importing a text file. To do so a field is required with a + (plus) character.  

The text file sample below will mark Alan Martin’s images as requiring retouching 

John, Smith,2222,100.jpg, 

Alan,Martin,3333,101.jpg,+ 

Alan,Martin,3333,102.jpg 

Steve,Bratt,4444,103.jpg, 

Checking the Set retouch option in the setup will present a field call Image-
retouch in the Field Map. In the sample text file above this would be mapped to 
field 5 

 

Note: When flagging a subject for retouching you are not flagging a particular image as requiring 
retouching.  When the subject is matched to more than image it is up to the user to select which image 
or images are to be retouched. With this in mind the + symbol in the sample above could have been 
against either of Alan Martin’s images. 

 

Set chromakey 

Earlier in this chapter we saw that it was possible to export data from a job with 
one of the special fields available for export being the chroma key profile 
generated when an image is keyed in the Timestone Software Chroma Key 
Module. 

This profile can also be imported via a text file and applied to the images 
automatically. This is useful if, for example, images that have been keyed in an 
earlier job are to be re‐imported into a new job. Importing the chroma key profile 
will mean the images do not have to be rekeyed in the Chroma Key Module. 

A typical chroma key profile is a very long text string (too long to be reproduced 
here) and is prefixed by %pmt.  

Checking the Set chromakey option in the setup will present a field call Image-
chromakey in the Field Map. Map this field to the field in the text file with the 
chroma key profile. 
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Displaying data within the software – As Tags 

As we have seen in the preceding pages, subject data is entered in Details Mode – 
either manually or by importing a text file. 

However there are many other areas of the software that display this data back to 
the user. These include: 

• Beneath the images in Images Mode 

• Beneath the images in Match Mode 

• In the subject list in Poses Mode and Form Packs Mode 

• In the Subjects to Include window whenever forming composites, item 
sheets or performing exports 

• Beneath the preview of pages in the print queue 

 

To a large degree the user can customize how this data is displayed by selecting 
which fields to display and whether to include fixed text or “special” fields. This is 
achieved with the As Tags function. 

1. Go To Details Mode>Edit Fields 

2. Click the As Tags button in the lower right corner 

The Details Tag Text window appears and contains two input areas. The first, 
Uniquely identifying text for item, is used to control what data to display in 
almost all areas of the software with the exception of the data beneath the images 
in Match Mode. This is controlled separately by the second input area, Identifying 
text when displayed in match table.  

As tags 
 

The subject listing in Form Packs Mode of 
NeoPack/Professional (shown at left) is 
one of the areas where data is displayed to 
the user. 

By default the software will show all data 
for all subject fields but it is possible to 
select which fields to display and also 
include fixed text (as in the Copywrite 2008 
at left) and “special” fields such as the 
image filename. 
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At installation both these input windows are blank. If left blank the software will 
display all fields which may be undesirable. To customize what data is to appear: 

3. Enter any field name by using the Insert field button to browse to a list of 
subject fields 

4. Alternatively enter the fieldname directly into the window. The fieldname 
must be preceded by an @ symbol 

Apart from subject fields it is also possible to enter “fixed” or static data. Any data 
entered without the @ symbol will be reproduced exactly as entered. 
Furthermore many system fields can be entered such as @folder to reproduce the 
name of the subject’s Home folder or @imagefilename to display the filename of 
the subject’s primary image. A full list of special fields can be found elsewhere. 

 

Note: Setting the tags as mentioned above is a job specific action – the tags will be saved with the 
current job but will not be present for new jobs. To be precise, the tags are saved with the current set of 
field definitions and therefore any of the methods described earlier for defining default fields (program 
defaults, workspaces, master jobs) also applies to the tags. 

 

 

 

 

 

 

 

 

As tags 
 

The Details Text Window (also known as 
the As Tags Window). 

The first input window controls how data 
is displayed in most areas of the software. 
The second input window controls what 
data to display in Match Mode 

Use the Insert field button to insert any 
subject field or simply enter the fieldname 
directly preceded by an @ symbol. Static 
or fixed text can also be entered along 
with a range of special “@codes” or 
system fields. 
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More As Tags implications – Backprinting and bitmap file naming 

As we saw above the As tags function (specifically the “item” window) is used to 
control the display of data in Form Packs Mode – both in the Subject list as well as 
part of the information displayed beneath each page in the print queue.  

The latter is also used by printers capable of backprinting data from third party 
software. In this case the user can control backprinting by simply editing the 
Uniquely identifying text for item section of the As tags window. 

 

Note: Most digital printers have a limit to the number of characters that can be backprinted. Exceeding 
this limit may result in the data being truncated or even a printer error. To avoid this situation use the As 
Tags function to control the amount of data passed for backprinting. Remember that if the As tags 
windows are left blank, all subject fields will be used.

 

Printing to file 

When printing from the software the option exists to print not just to digital 
printers but also to bitmap files – jpegs, tiffs etc.  Furthermore the option also 
exists to name the files with data from the software.  In this case the files will be 
named as per the subject listing in Form Packs Mode – in other words as per the 
Uniquely identifying text for item section of the As tags window. 

 

 

 

 

 

 

Backprinting 
 

A page in the print queue waiting to be 
printed. The information below the preview 
is controlled, in part, by the As tags function.  

The data up to and including the Copywrite 
information was defined in the Uniquely 
identifying text for item section of the As 
tags window, while 8” Long Pack (1) is the 
name of the product ordered. 

This text string will be used for backprinting 
by supported printers and (optionally) as the 
filename when the page is printed to file. 

 


